Uploaded image for project: 'FreeSWITCH'
  1. FreeSWITCH
  2. FS-10173

Lua print function goes to stdout, not to the output of the lua command

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not A Bug
    • Affects Version/s: 1.6.15
    • Fix Version/s: None
    • Component/s: Configuration
    • Labels:
      None
    • Environment:
      Linux fs 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
    • CPU Architecture:
      x86-64
    • Kernel:
      Linux
    • uname:
      Linux fs 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
    • Userland:
      GNU/Linux
    • Distribution:
      Debian
    • Distribution Version:
      Debian 8 jessie
    • lsb_release:
      Hide
      No LSB modules are available.
      Distributor ID: Debian
      Description: Debian GNU/Linux 8.7 (jessie)
      Release: 8.7
      Codename: jessie
      Show
      No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 8.7 (jessie) Release: 8.7 Codename: jessie
    • Compiler:
      gcc
    • FreeSWITCH GIT Revision:
      FreeSWITCH Version 1.6.15-32-bec4538~64bit (-32-bec4538 64bit)
    • GIT Master Revision hash::
      f19fcdb4f0c176811039c497376da2b76db0c2f8
    • Target Version:

      Description

      Debian 8
      FreeSWITCH (Version 1.6.15 -32-bec4538 64bit)

      1. Login Debian with root.
      2. Install the FS by apt-get.
      wget -O - https://files.freeswitch.org/repo/deb/debian/freeswitch_archive_g0.pub | apt-key add -
      echo "deb http://files.freeswitch.org/repo/deb/freeswitch-1.6/ jessie main" > /etc/apt/sources.list.d/freeswitch.list
      apt-get update && apt-get install -y freeswitch-meta-all
      3. Run fs_cli after install.
      4. Run [lua ~print("hello world!")] in fs_cli.
      5. Get an error message in fs_cli: -ERR no reply
      6. Stop the fs with [systemctl stop freeswitch.service] command.
      7. Run [freeswitch -c] command set the fs in the foreground.
      8. Run [lua ~print("hello world!")] in fs_cli and get the correct result.
      9. I try to run the lua after fs startup in the background ([freeswitch -nc] and [freeswitch -ncwait]). Get the same error.

      Who can tell me why the lua does not working when fs startup with service mode and background mode?
      Is it a bug?

      Thanks a lot!

        Attachments

        1. right.png
          right.png
          9 kB
        2. wrong.png
          wrong.png
          7 kB

          Activity

            People

            • Assignee:
              brian@freeswitch.org Brian West
              Reporter:
              zzyroy zzy
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: