Uploaded image for project: 'FreeSWITCH'
  1. FreeSWITCH
  2. FS-10547

record_session filename.mp4 empty when calling from verto to sofia

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: New
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: core, mod_av, mod_verto, RTP
    • Labels:
      None
    • CPU Architecture:
      x86-64
    • Kernel:
      Linux
    • Userland:
      GNU/Linux
    • Distribution:
      Debian
    • Distribution Version:
      Debian 8 jessie
    • Compiler:
      gcc
    • FreeSWITCH GIT Revision:
      4113000
    • GIT Master Revision hash::
      4113000

      Description

      when calling from verto (using verto comunicator) to a sip endpoint and recording the video call the resulting file is empty.

      Using vanilla conf with changes:
      <X-PRE-PROCESS cmd="set" data="global_codec_prefs=OPUS,G722,PCMU,PCMA,VP8,H264"/>

      and dialplan rule:
      <extension name="record" continue="false">
      <condition field="destination_number" expression="^10\d+">
      <action application="set" data="enable_file_write_buffering=false"/>
      <!--<action application="set" data="media_bug_answer_req=true"/> -->
      <action application="record_session" data="/home/tmp/${strftime(%Y-%m-%d-%H-%M-%S)}${caller_id_number}${destination_number}.mp4"/>
      <action application="bridge" data="[^^:absolute_codec_string=PCMU,PCMA,H264,VP8]user/${destination_number}@192.168.8.254"/>
      </condition>
      </extension>

      Calling from SIP to Verto is OK, the audio and video are recorded correctly.

      Attach both logs.

        Attachments

          Activity

            People

            • Assignee:
              mikej Mike Jerris
              Reporter:
              antonio Antonio
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: