Uploaded image for project: 'FreeSWITCH'
  1. FreeSWITCH
  2. FS-7958

FS crash on streaming rtmp of desktop share

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: 1.6
    • Component/s: verto
    • Labels:
      None
    • Environment:
      Debian Jessie
    • CPU Architecture:
      x86-64
    • Kernel:
      Linux
    • uname:
      Linux anton-jessie-fs-003 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux
    • Userland:
      GNU/Linux
    • Distribution:
      Debian
    • Distribution Version:
      Debian 8 jessie
    • Compiler:
      gcc
    • FreeSWITCH GIT Revision:
      7cf1238137d8876a1a34d28a54d60d328c44d895
    • GIT Master Revision hash::
      facf08516c690f8640fd50b639bb37714ea43838
    • FSS Support Agreement Customer Number and Company name:
      Blindside Networks

      Description

      Hello!

      I have been seeing FreeSwitch crash lately. I am using the code from the master branch. The work I have been doing with FreeSwitch is related to desktop sharing and broadcasting to an rtmp stream.
      The machine is running Debian Jessie (see uname -a under).

      This is the typical behaviour just before FreeSwitch crashes:
      Typically at the moment of the crash FS has initiated desktop sharing and broadcasting to rtmp is under way. Sometimes I am able to also stop broadcasting to rtmp before the crash occur.

      I attach the log from FreeSwitch CLI(24358) and backtrace from the coredump(24357).

      $ sed '/$/!H;/$/x;$!d' /proc/cpuinfo
      processor : 1
      vendor_id : GenuineIntel
      cpu family : 6
      model : 42
      model name : Intel Xeon E312xx (Sandy Bridge)
      stepping : 1
      microcode : 0x1
      cpu MHz : 3392.294
      cache size : 4096 KB
      physical id : 1
      siblings : 1
      core id : 0
      cpu cores : 1
      apicid : 1
      initial apicid : 1
      fpu : yes
      fpu_exception : yes
      cpuid level : 13
      wp : yes
      flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq vmx ssse3 cx16 pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt vnmi ept
      bogomips : 6784.58
      clflush size : 64
      cache_alignment : 64
      address sizes : 40 bits physical, 48 bits virtual
      power management:

      I have changed some dialplan basic config -
      <extension name="cdquality_conferences">
      <condition field="destination_number" expression="^(35\d

      {2}

      )-screen$">
      <action application="conference" data="$1-DESKSHARE@video-mcu-stereo"/>
      </condition>
      </extension>

      Regards,
      Anton Georgiev

      P.S. The logs are from a couple commits ago but I just updated to latest and I can reproduce the issue.

        Attachments

        1. 24357.txt
          185 kB
        2. 24358.txt
          137 kB

          Activity

            People

            • Assignee:
              mikej Mike Jerris
              Reporter:
              antobinary Anton Georgiev
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: