Uploaded image for project: 'FreeSWITCH'
  1. FreeSWITCH
  2. FS-8348

Segmentation fault (core dumped)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: mod_av, mod_vlc
    • Labels:
      None
    • Environment:
      Debian 8
    • CPU Architecture:
      x86-64
    • Kernel:
      Linux
    • Userland:
      GNU/Linux
    • Distribution:
      Debian
    • Distribution Version:
      Debian 8 jessie
    • Compiler:
      gcc
    • FreeSWITCH GIT Revision:
      FreeSWITCH Version 1.7.0+git~20151013T205046Z~bf8d10f3b4~64bit
    • GIT Master Revision hash::
      git bf8d10f 2015-10-13 20:50:46Z 64bit
    • Target Version:
      1.6

      Description

      FreeSWITCH Version 1.7.0 on Debian 8. Clean installation. I am trying to make a call to 1004 in 1003
      Simple dialplan

      <extension name="test4">
       <condition field="destination_number" expression="^(6083)$">
         <action application="export" data="nolocal:absolute_codec_string=VP8,OPUS"/>
         <action application="set" data="hangup_after_bridge=true"/>
         <action application="set" data="RECORD_STEREO=true"/>
         <action application="export" data="RECORD_TOGGLE_ON_REPEAT=true"/>
         <action application="export" data="record_concat_video=true"/>
         <action application="bind_meta_app" data="2 a i record_session::/usr/local/freeswitch/recordings/${strftime(%Y%m%d_%H%M%S)}_${destination_number}_a.mp4"/>
         <action application="bind_meta_app" data="2 b i record_session::/usr/local/freeswitch/recordings/${strftime(%Y%m%d_%H%M%S)}_${destination_number}_b.mp4"/>
         <action application="answer"/>
         <action application="bridge" data="user/1003${sip_profile}"/>
       </condition>
      </extension>

      When I start to record video with the help of mod_vlc (with mod_av the same result), beautifully crafted file. Writes about 3-5 minutes (always different) and then crash freeswitch with error "Segmentation fault (core dumped)". The log is nothing critical

      2015-10-14 18:00:08.727101 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:17.667098 [DEBUG] switch_core_media.c:2030 37bb2d93-701b-4b5e-8e6d-b51dc2b2b213 sofia/internal/3pdl5ns9@elvq5f8dpe6i.invalid "Extension 1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:17.667098 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:18.717096 [DEBUG] switch_core_media.c:2030 b6beadf0-c5c6-47a0-a6e5-ea7539922589 sofia/internal/1004@sip1.applicloud.com "1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:18.717096 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:27.707101 [DEBUG] switch_core_media.c:2030 37bb2d93-701b-4b5e-8e6d-b51dc2b2b213 sofia/internal/3pdl5ns9@elvq5f8dpe6i.invalid "Extension 1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:27.707101 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:28.727097 [DEBUG] switch_core_media.c:2030 b6beadf0-c5c6-47a0-a6e5-ea7539922589 sofia/internal/1004@sip1.applicloud.com "1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:28.727097 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:37.747097 [DEBUG] switch_core_media.c:2030 37bb2d93-701b-4b5e-8e6d-b51dc2b2b213 sofia/internal/3pdl5ns9@elvq5f8dpe6i.invalid "Extension 1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:37.747097 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)
      2015-10-14 18:00:38.757097 [DEBUG] switch_core_media.c:2030 b6beadf0-c5c6-47a0-a6e5-ea7539922589 sofia/internal/1004@sip1.applicloud.com "1004" Sync A/V JB to 300ms 4 VFrames FPS 30 a:yes v:no
      2015-10-14 18:00:38.757097 [DEBUG] switch_core_media.c:1937 Setting Jitterbuffer to 300ms (15 frames) (30 max frames)

      and then crash on the file core.хххх If you want, I can send it too. It is about 500 megabytes

      What am I doing wrong?

        Attachments

          Activity

            People

            • Assignee:
              mikej Mike Jerris
              Reporter:
              DexCZ Denis Jakovlev
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: