Uploaded image for project: 'FreeSWITCH'
  1. FreeSWITCH
  2. FS-9829

FreeSWITCH 200ok to second reINVITE on a dialog doesn't contain an SDP.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.13, 1.8
    • Fix Version/s: 1.8
    • Component/s: mod_sofia
    • Security Level: public
    • Labels:
      None
    • CPU Architecture:
      x86-64
    • Kernel:
      Linux
    • Userland:
      GNU/Linux
    • Distribution:
      Debian
    • Distribution Version:
      Debian 8 jessie
    • Compiler:
      gcc
    • FreeSWITCH GIT Revision:
      N/A
    • GIT Master Revision hash::
      N/A

      Description

      When we receive the reinvite we generate an SDP,
      1. ccac176c-5b3a-480e-b38a-dd00aab15548.log
        44 kB
        Antonio
      2. reinvite_t38_200ok_no_sdp_filtered.pcap
        516 kB
        Antonio
      3. t38_outbound.xml
        6 kB
        Brian West
      1. reinvite-notsent.png
        71 kB

        Activity

        Hide
        brian Brian West added a comment -
        Test my sipp scenario, it will replicate the issue, My situation was the same where the remote had sent me another reinvite with audio, prior to switching to t38, thats the key to replicating this particular issue.

        I can now replicate it on demand.

        /b
        Show
        brian Brian West added a comment - Test my sipp scenario, it will replicate the issue, My situation was the same where the remote had sent me another reinvite with audio, prior to switching to t38, thats the key to replicating this particular issue. I can now replicate it on demand. /b
        Hide
        antonio Antonio added a comment -
        Brian, i couldn't reproduce with your sipp cenario, it gives me an error:

        2016-12-13 18:16:37.454118 1481649397.454118: media_port keyword with no audio or video on the current line (
        m=image ).
        Show
        antonio Antonio added a comment - Brian, i couldn't reproduce with your sipp cenario, it gives me an error: 2016-12-13 18:16:37.454118 1481649397.454118: media_port keyword with no audio or video on the current line ( m=image ).
        Hide
        mikej Mike Jerris added a comment -
        think this scenario requires latest sipp (you may have to build from source)
        Show
        mikej Mike Jerris added a comment - think this scenario requires latest sipp (you may have to build from source)
        Hide
        brian Brian West added a comment -
        Yes you MUST use the very latest SIPP, I used 3.5.1.

        /b
        Show
        brian Brian West added a comment - Yes you MUST use the very latest SIPP, I used 3.5.1. /b
        Hide
        antonio Antonio added a comment -
        solved! thanks was my sipp version.
        Show
        antonio Antonio added a comment - solved! thanks was my sipp version.

          People

          • Assignee:
            mikej Mike Jerris
            Reporter:
            brian Brian West
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development